5
(1)

Обновления в WordPress пугают многих новичков, особенно это предупреждение на странице обновлений, где рекомендуется создать перед процедурой резервную копию сайта. Зачем? Неужели всё может сломаться и все труды будут утеряны?

В этой статье рассматриваем, что плохого может случиться от обновления, надо ли создавать резервную копию сайта, и что делать, если WordPress после обновления не работает совсем.

От чего обновление в WordPress может привести к проблеме

Есть несколько факторов риска, при которых очередное обновление в WordPress может привести к неполадке так, что сайт работать перестанет:

  • Если вы пользуетесь некачественным хостингом, на котором установлено слабое оборудование, то во время обновления может возникнуть проблема, которая не даст процессу корректно завершиться и в лучшем случае обновление не произойдёт, а в худшем — сайт перестанет работать. Обычно такое бывает на бесплатных хостингах или на некоторых платных в самых дешёвых тарифах. Но иногда случается и на хороших хостингах.
  • Ещё одно влияние хостинга — устрашившее программное обеспечение, которое на нём установлено. Если, например, WordPress или какой-то плагин обновляются до такой степени, что его уже не поддерживает не актуальное серверное ПО, то сайт работать перестаёт. Этим также страдают бесплатные или дешёвые хостинги.
  • Если вы используете на сайте плагины или темы, которые уже не поддерживаются разработчиком, не обновляются, то есть вероятность, что они приведут к проблеме при очередном обновлении WordPress. CMS будет развиваться дальше, а плагины останутся не актуальными. В результате в WordPress появятся какие-то новые технологии и устаревшие перестанут использоваться, и если какую-то из этих технологий применял устаревший плагин, то он работать перестаёт, а иногда и тянет за собой весь сайт. Однако, надо заметить, что некоторые плагины не обновляются разработчиками годами и продолжают работать в любой версии WordPress как нужно.

Ниже рассмотрим, что делать при возникновении проблемы в WordPress после обновления.

Сайт ненадолго закрыт на техническое обслуженные. Зайдите через минуту.

Если после обновления WordPress, переходя на сайт, вы видите сообщение «Сайт ненадолго закрыт на техническое обслуженные. Зайдите через минуту.» (или это же, но на английском языке), то это значит, что обновление началось, но не смогло корректно завершиться. Если вы обновите страницу через минуту, то всё равно увидите это сообщение, и даже если пройдёт больше времени, сообщение останется.

Решается проблема просто. Во время обновления WordPress создаётся файл с именем .maintenance, который закрывает сайт на техническое обслуживание, чтобы во время обновления никто им не мог пользоваться. Само обновление всегда происходит в течение минуты. Если оно происходит дольше, то это в большинстве случаев означает, что что-то пошло не так, и скорее всего обновление уже не завершится.

Соответственно, чтобы начать далее пользоваться сайтом, нужно удалить файл .maintenance, зайти на сайт и сделать обновление заново. Файл .maintenance создаётся в разных папках для каждого продукта:

  • Если вы обновляли WordPress, то .maintenance находится в корневой папке сайта.
  • Если вы обновляли плагины, то .maintenance находится в папке wp-content/plugins.
  • Если вы обновляли тему, то .maintenance находится в папке wp-content/themes.

Удалить файл вы можете в файловом менеджере вашего хостинга.

Не подходящая версия PHP

WordPress, темы и плагины обновляются и меняют поддерживаемые технологии — удаляют старые поддержки и заменяют их на новые, более совершенные. Для того чтобы они работали нормально, программное обеспечение хостинга также должно поддерживать эти технологии. Поэтому оно тоже обновляется.

У пользователя хостинга есть возможности гибко управлять версией PHP для своего сайта. PHP — это программа на хостинге.

Версия PHP

Если после обновления WordPress не работает, то, возможно, теперь пришло время повысить версию PHP. Так, на данный момент самая последняя версия PHP 8.0. Но это не значит, что нужно срочно переводить все свои сайты на эту версия. Большинство плагинов и тем ещё не успели внедрить её поддержку. Несмотря на то, что это последняя версия, самой популярной версией на момент создания этой статьи является 7.1.

Поэтому поэкспериментируйте с версией PHP, если обновление в WordPress привело к проблеме.

Несовместимости

Обновление может привести к несовместимости плагинов и тем. Например, если какой-то плагин обновится, он по какой-то причине может стать не совместимым с активированной темой. И если активировать другую тему, то проблема пропадает, а с нужной темой не работает.

Здесь можно пытаться решить проблему разнообразными способами. Во-первых, если после обновления произошла несовместимость, и сайт вообще не работает, то нужно восстановить сайт из резервной копии на тот момент, когда обновление ещё не было выполнено. Вот тут как раз тот редкий момент, когда нужна резервная копия сайта при обновлении.

Во-вторых, нужно понять, что именно стало несовместимым. Если вы обновляли что-то одно, то очевидно, что именно это вызывает проблему, а если несколько, например, десяток плагинов, то придётся искать методом исключения.

После обнаружения виновника несовместимости следует попытаться найти для него замену и устранить таким образом проблему.

Насколько публикация полезна?

Нажмите на звезду, чтобы оценить!

Средняя оценка 5 / 5. Количество оценок: 1

Оценок пока нет. Поставьте оценку первым.